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FUN WITH PHOTOS (PART 1)

Goals for the Day:
• Become familiar with Gimp, the photo-manipulation program we’ll be 

using today.
• Learn how to find photos you can legally use in your artwork.
• Learn how to cut people and objects out of photos.
• Learn how to ‘mash up’ different photos.

Key Terms:
• bitmap - an image stored on a computer or on the web that is literally a 

grid of squares (‘pixels’) filled in with different colors. All photographic 
computer images are stored as bitmaps - you can see the map when you 
zoom way in on a photo on the computer. (sometimes called ‘pixmap,’ 
sometimes called ‘raster’)

• license - the permission the creator of an artwork or document has given 
you to use it. If an image is licensed “Copyright, All rights reserved” then 
you do not have permission/rights to use it. If an image is licensed “Public 
Domain” then you may freely use it. 

• mask - a mask is a shape or form that you apply to an image to allow you to 
hide some parts of the image, and show others. 

• pixel - if you think of a photo on the computer as a bitmap, a grid of 
squares filled in with all different colors, each square in that grid is 
considered a pixel. Computer graphics are made up of many tiny pixels.

• resolution - a measure of the quality of a digital image. The more pixels a 
bitmap has, the higher-quality the image will appear when you zoom out 
from the grid. Sometimes digital cameras let you know the resolution of the 
photos they take using a unit called ‘megapixels.’

Question of the day:

If you could visit anywhere in the world (or even in space!), where would you 
want to go?
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Activity 1: Find a photo

Remember when you thought about where you’d like to visit someday? We’re 
going to put you there! First, you’ll need to find a photo of the place you’d like to 
visit.

The best place to find a photo that has a friendly license (more on that later) is to 
use the Creative Commons search tool. Go ahead and visit it in your browser:

http://search.creativecommons.org

The three search tabs on that site that you’ll find most useful are:
• Google (Image)
• Flickr (Image)
• Mediawiki Commons (Media)

Go ahead and use those tabs for an image of your dream destination, being 
careful to find one that is of a good resolution. Photos that are at least 1024 x 768 
(1,024 pixels wide and 768 pixels tall) tend to be a good enough quality to use.

Can’t think of a place you’d like to visit? Here’s some suggestions of places you 
might have fun looking for a photo of:

• the surface of the moon
• Las Vegas!
• Harajuku Dori, a popular street in Tokyo
• An African safari with lions and zebras
• A tropical cruise ship
• Hollywood, CA
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Once you find the perfect image (or image(s), if you can’t make up your mind!:

• Bookmark it.  In Firefox, go to the Bookmarks > Bookmark this page menu 
item.

• Save it to your computer. Right-click the image and select, “Save Image 
As...” in the menu that pops up. A good place to save it is on ‘Desktop.’

While you look for a photo, we’ll be taking pictures of everyone in the class - we’ll 
take a photo of you that you can use to transport yourself into the location you’ve 
chosen. 
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Activity 2: Explore the Gimp!

The Gimp is a bitmap editing program. It’s similar to apps like Photoshop®, which 
you may have heard of. The two apps do a lot of the same things; the big 
difference between the two is that the Gimp is free.

To open up the Gimp, you can double-click on the Gimp icon on your desktop, 
which looks like this:

You can also open it up using the ‘Applications’ menu in the upper right of your 
screen. Go to Applications > Graphics > GNU Image Manipulation Program.

Once you’ve got Gimp open, there’s three ways you can open up your dream 
destination photo in it:

• You can right-click your photo file, and select “Open With” then “GNU 
Image Manipulation Program.”

• You can drag the photo file on top of the Gimp window.
• You can go to the File > Open menu in Gimp and select your photo file that 

way.

While you wait to get the photo we’ll be taking of you, take some time to explore 
Gimp’s interface using the dream destination photo you downloaded. As you 
come up with questions about how to use Gimp, please write them down for our 
questions period later! (You can click on the Gnote icon on the top of your screen 

to take some notes. It looks like this:   )

If you double-click on the ‘Help’ folder on your desktop, you’ll find there’s a 
couple of Gimp books you can take a look at in your explorations. One is called 
“Gimp Manual” and the other is “Gimp Savvy.” 

If you’re not sure what to do as you explore, here’s some things to try:

• Blur the photo, and make it black & white.
• Undo the blur and black & white you just did!
• Copy and paste the photo into a new layer.
• Draw stick figures in the photo, or if there are people in the photo, give 

them moustaches!
• Add a coffee stain to the photo.
• Warp the photo so it looks like it’s an image in a funhouse mirror.

The next page gives you a brief overview of the Gimp interface to serve as a 
handy guide! 
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Activity 3: Free yourself from your photo!

By now you should have a copy of the file that contains the photo we took of you
during class. Let’s try to put the photo of you in the photo you found of a dream
destination.

So I’m starting out with a cool photo of the Louvre Museum in Paris, France - but
when I drag my photo on top of it, it completely covers up the Louvre! I just want
myself in the Louvre photo, not all of the background behind me:

I’d prefer the photo to look 
something like this one, on the 
left.

How is this done?
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Opening two photos in the same Gimp image

First, insert your photo into the dream destination photo as a layer. There’s a
couple of ways you can do this:

• Open your dream destination photo in the Gimp. Then, drag your photo file 
on top of the dream desintation photo window of the Gimp. 

• Go to the Gimp ‘File > Open as Layers’ menu item and select your photo file.

Once your photo is in the Gimp, you should see it and your dream destination
photo, each on their own layer in the Gimp:

Exercises
Here’s a few things to try now that you’ve got a 
couple of layers in your image:

• Select your photo, and click the down arrow along 
the bottom of the layers palette. What happens?
• Now, with your photo selected, click the up arrow.
• With your photo on the top of the layer stack, drag 
the opacity handle down so it’s 50% opacity or so. 
What happened? (Okay, now drag it back to 100%!)

Removing yourself from a photo (or, layer masking!)

With your photo on the top layer and your dream destination on the bottom
layer, we’re going to add something called a layer mask. Layer masks are a kind
of cut-out you place on top of a layer. Masks can be black, white, or shades of
grey. The parts of a mask that are black will hide the parts of the layer they apply
to; the parts that are white will show the parts of the layer they apply to. Here’s
an example:
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So you can image a mask as being a kind of stencil on top of a layer. To remove 
the background behind you in your photo, you’ll need to create a mask that 
blocks out the background around you.

To create a mask:
1 Make sure the layer that has your photo is on the top of the layer stack in 

the layers palette.
2 Right click the layer with your photo in it, and select ‘Add Layer Mask...’ in 

the menu that appears.
3 A little window will pop up asking you what you would like to ‘initialize’ 

the layer mask to. Don’t worry about this dialog, just click the ‘Add’ button.
(By default, this will create a white / ‘full opacity’ layer mask.)

Now your layers dialog will look something like this:

See how there’s now a white square to the right of 
your photo? That white square is your mask.
Since it’s full filled in white, everything in your photo 
is showing through.

Exercises
• Fill the layer mask in with the color black. You can do this by clicking on 

the paint bucket icon in the toolbox, selecting the color black in the color 
selector, and clicking on the image. What happens?

•  Now, fill in the the layer mask with a grey color. What happens?
• Fill the layer mask back in with white. Now, click on the paintbrush tool, 

select the color black, and start drawing on the layer mask. What happens?
• Now try to fill your photo in black. It doesn’t work, right? It only affects the 

layer mask.
• Right click the layer with your photo and the layer mask, and uncheck the 

‘Edit layer mask’ box. Now try to fill in your photo.
• Undo the fill you just did (Hit the Ctrl+Z keys on the keyboard, or go to the 

Edit > Undo item in the Gimp menu.) Right click your layer and check the 
‘Edit layer mask’ box again.

• Right click your layer and check ‘View layer mask.’ Now you can see only 
the layer mask and not your photo. Draw your name on the layer mask 
using a black brush. Now right click your layer and uncheck ‘View layer 
mask.’ What happened?
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Go ahead and erase you layer mask now - fill it in completely white. (A quick way 
to do this is to right click the layer and select ‘Delete Layer Mask’, then right click 
it and select ‘Add Layer Mask’ to create a fresh one.)

Take a thick black brush (you can increase the size of your brush using the ‘Scale’ 
slider at the bottom of the Brushes palette in the lower right of your screen.) Use 
that brush to draw around yourself in your photo. You should start seeing your 
dream destination behind you wherever you draw. Don’t worry if you make any 
mistakes, we can go back and fix them.

Once you’ve completely traced around your photo, fill everything outside of your 
photo in with black with the paint bucket tool, and erase any lines that are lying 
around.

If you accidentally erase any part of your photo, you can switch to using a white 
brush to paint those parts of your photo back into the picture. Once you’re done, 
you should have a photo of yourself at your dream destination!

Congratulations, you did it!
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Questions
• Where can you find safely-licensed photos on the internet?

• How do you open up multiple photos in the same image file in the Gimp?

•  How would you describe what image layers are when explaining them to 
a friend?

• What's the best way to extract a person or object out of a photo?

Extra Credit
• What are the advantages to using layer masks over using the eraser tool?
• Use the techniques you learned today to create a photo of yourself standing 

next to your favorite celebrity.

Licenses to Look For:

Here’s some licenses that are particularly friendly for photo manipulation experts 
such as yourselves:

• Public Domain - anything marked as public domain you can use freely 
under whatever license you choose and without having to credit anyone.

• Creative Commons Attribution - if you make a piece of art using a 
Creative Commons Attribution piece of artwork, you must give credit 
(‘attribution’) to the original artist.

• Creative Commons Attribution ShareAlike - if you make a piece of art 
using a Creative Commons Attribution ShareAlike piece of artwork, you 
must give credit (‘attribution’) to the original artist and you must license 
the work under the same Creative Commons License.

• GPL - if you make a piece of art using a GPL piece of artwork, you must 
give credit (‘attribution’) to the original artist and you must license the 
work under the GPL.

Photo Credits:
   •    “Le Louvre” by re-ality on Flickr. Used under a Creative Commons Attribution 3.0 license.
   •    “Pony” by Steve Lodefink on Flickr. Used under a Creative Commons Attribution 2.0 license.
   •    “Sleeping Pony” by erix! on Flickr. Used under a Creative Commons Attribution 2.0 license.
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